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1 Workstation planning
Workstation Planning helps planners solve the complex challenges involved in assigning qualified
personnel to shifts, jobs and workstations. Especially where there are many variables (e.g. different
time blocks, activities, tasks or workplaces), Workstation Planning gives a planner the quick
overview of possibilities they need and offers the functionality to guarantee appropriate staffing
throughout multiple scheduling stages.

Workstation planning enables planners to plan at a task level. When adding workstations as an
extra component to a shift you can allocate employees to specific locations and/or times. A
timeline overview shows the shifts and workstations, while the system checks capacity in real-time.
To effectively use workstation planning, a good understanding of duties, skills, activity types and
master schedules is required.

1.1 Indirect or direct planning
Plan workstations indirectly through duties or directly by assigning workstations to employees
based on their availability. Workstation assignment can be done manually or automatically via the
workstation optimizer. The use of workstation planning will dictate the necessary configuration in
ORTEC Workforce Scheduling.

We'll outline the common use cases for workstation planning. Your organization's project manager
or implementation consultant can provide more information if additional features are necessary.
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2 Configuration
Locations and workstations are an essential part of workstation planning. A workstation can be
anything from a physical location, room, office, device, or machine where employees perform their
tasks. Workstations are defined at the location level, and a hierarchical structure of locations is
created to reflect your organizational structure.

Workstation demands allow you to specify the number of employees required at each workstation
during specific times. This information is used to check for under- or overstaffing and generate a
workstation planning. Workstation demands are valid for the whole organization. However, when
accessing a workstation demand, you'll only see the workstations that are relevant to your
department. This approach allows for the creation of cross-department workstation demands that
can be used by multiple departments at once.

2.1 Locations and workstations

2.1.1 Add locations
The first step in workstation planning, is to define the locations of the workstations.

1. Go to Maintenance > Locations and workstations.
2. In the left pane, select the level under which you want to create a new location.
3. Click the New button.

Example

4. Enter the name of the new location.
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5. Click OK. The new location appears in the location structure.
6. (Optional) Define the Properties of each workstation. Make sure to add a Code when you

want to exchange information with an external system.

2.1.2 Edit or delete locations
1. Go to Maintenance > Locations and workstations.
2. In the left pane, select the location you want to edit or delete.

Example

3. n To edit a location, click the Change location name button. Change the name and click
OK.
The altered location is updated immediately throughout the application.

n To delete a location, click the Delete the selected location button. To confirm, click
Yes.

A location can only be deleted if it doesn't have any lower level locations or
workstations.

2.1.3 Add workstations to locations
After locations have been defined, workstations can be added.

1. Go to Maintenance > Locations and workstations.
2. Select the location to which the new workstation belongs.
3. Select the Workstations tab.
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4. In the Workstations section, click New button.

Example

n Define a Name for the new workstation.
n (Optional) Make the new workstation a copy of an existing workstation. Select one

from the drop-down list.

It's also possible to copy an existing workstation and change its attributes.

n Click OK.
All workstations are sorted alphabetically according to name.

4. Select the Department for which the workstation should be made available.

Example

Select a department higher up in the organization structure to make the workstation available
for all departments belonging to that department.
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5. Select the Activity type that is performed on the workstation. No activity types other than the
selected one can be performed on this workstation.

You can also set the selected activity type as the default option while maintaining the ability to
perform other activity types on the workstation.

To do so, enable setting UseDefaultActivityTypeForWorkstation via ORTEC WS Settings manager >
General settings. Once the processes are restarted, the Activity type column will read Default
activity type.

6. (Optional) Select a sort category to which the workstation will belong.
This enables sorting on workstations in the plan board.

7. (Optional) Add a description of the workstation in the Description column. This description
will be shown as hint text in the master schedule.

8. (Optional) Assign one or more required skills to a workstation. This can be relevant when you
use activity types for which no skills are defined, or when multiple activity types are allowed
on the workstation but the workstation always requires a certain skill.

If the Workstations tab does not have a Skills section, follow these steps:

a. Close the ORTEC WS client.
b. Open the ORTEC WS Settings Manager.
c. Go to the General settings tab.
d. Look for the UseSkillsForWorkstation option and enable it.
e. Restart the processes in ORTEC System Configuration.
f. Open the ORTEC WS client again. The option to use skills for the workstations should

now be visible.

n Select the workstation to which you want to assign one or more required skills.
n In the Skills section, click the New button.
n From the list of available skills, select the one you want to assign to the workstation.
n Click OK.
n (Optional) Define a skill level.

The skill is now assigned to the workstation. Repeat these steps to add more required
skills to the workstation.

9. To show a workstation in either the right-mouse menu Replace by workstation on the master
schedule planning board or the right-mouse menu Change workstation on the workstation
planning board, select the checkbox Show in pop-up menu of the planning board.

10. To make a connection between a workstation and the Time & Attendance application, select
the checkbox This workstation is registered for the T&A application. This might be relevant
when hours on a specific activity type need to be billed. Enter the code.

11. Define the default Color for a workstation, so it's easy to recognize on the workstation
planning board.
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2.1.4 Edit or delete workstations
1. Go to Maintenance > Locations and workstations.
2. In the Workstations tab, select the workstation you want to edit or delete.

n To edit a workstation, click the Change button. Change the name and click OK.
The altered workstation is updated immediately throughout the application.

n To edit the attributes of a workstation, simply change the fields by selecting the
appropriate cells.

The department of a workstation can be changed only if the workstation:

n doesn't have workstation demands for the department
n isn't used in calculations, duties etc.
n isn't assigned to an employee
n isn't used in a workstation optimizer profile

n To delete a workstation, click the Delete button. To confirm, click Yes.

A workstation can only be deleted if the workstation:

n doesn't have workstation demands
n isn't used in calculations, duties etc.
n isn't assigned to an employee
n isn't used in a workstation optimizer profile

2.1.5 Location properties

Use location properties to distinguish between workstations/locations in various calculation rules.
For example to book all hours worked on specific locations.

Via ORTEC WS Settings Manager > General settings, enable the setting UsePhysicalLocationProperties
and restart the processes. This will activate the Location properties definition and Location
properties values tabs.

Manage location properties definitions

1. Go to Maintenance > Locations and workstations.
2. In the left pane, select the location at the highest level.
3. Select the Location properties definition tab.
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4. To add a new location property, click the New button.

Example

n Enter a Name.
n Click OK.
n Double click in either the Property, Abbreviation, or Default value cell to make

changes. From the Type drop-down list you can select another type.
5. To create a new Access Control permission for this property, select the checkbox Use read

and write authorization to shield values for this feature. Once created, you can set read and
write permissions for this property in Access Control.

6. Per property, define the Restrictions. The restrictions determine the possible values for non
Yes/No based properties.

n No restrictions
All values are permitted.

n Values between n and n
n Permitted values
n Click Save.

7. To edit or delete a property, select it and edit or click the Delete button.

Manage location properties values

1. Go to Maintenance > Locations and workstations.
2. In the left pane, select the location for which you want to add values.
3. Select the Location properties values tab.
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4. To add a new location property value, click the New button.

Example

n Select a Property from the drop-down list.
n Define a Value.
n Define the Period during which this value is valid. No end time is required.
n Click OK.

5. Repeat step 4 to add more location property values.
6. To edit or delete a location property value, select it and click either the Open or Delete

button.

2.2 Workstation demands
Set the demand for each workstation per day of the week or for a specific date. Or, create multiple
demands, for example one with high demand and one with lower demand.

2.2.1 Add and/or view workstation demand sets

n A workstation demand set is not defined for a specific department. In the Maintenance
workstation demand section you have an overview of all workstation demand sets that exist.
However, once you open one of the workstation demand sets, the only workstations that are
shown are the ones valid for selected department.

n Because of maintenance and administrative reasons, it's wise to create one (or
more) separate workstation demand sets for each department.

1. Go to Planning > Schedule management.
2. Select a department.
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3. Select the Workstation demand tab.
4. (Optional) To add a new workstation demand set, click - in the Maintenance workstation

demand section - the New button.

Example

n In the New Workstation demand screen, enter a Name.
n (Optional) Make the new workstation demand set a copy of an existing workstation

demand set. Select one from the drop-down list.
n Click OK.

5. In the Maintenance workstation demand section, select a workstation demand set.
6. Click the Open button.
7. The Workstation demand window will appear. The workstations previously defined via

"Locations and workstations" on page 2 and applicable for the selected department (step 2)
are shown.
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Select one of the following:

n a Day of the week from the drop-down menu on the top-left side of this window, or
n a Date by using the calendar option (typing the date is also possible).

By using one of these options, the window will be set into either day or date mode. 

n In day mode, only recurring workstation demands are shown (recurring on that
specific weekday). They're recognizable by their blue colored bars in the
workstation demand overview.

n In date mode, both recurring demands and date specific demands are shown.
Date specific demands are recognizable by their green colored bars in the
workstation demand overview.

n At the bottom-left corner of the window, set the horizontal Scale (minutes). This scale
varies from 1 minute to 60 minutes.

The time bars shown in the workstation demand overview have limited space for
textual information. More detailed information can be acquired via the hint text. A hint
text is a text shown when hovering over a time bar in the workstation demand overview
with your mouse.



11
User Manual Module Workstation Planning ORTEC Workforce Scheduling 7
Configuration © 2025, All rights reserved

2.2.2 Add demands per workstation
1. Go to Planning > Schedule management.
2. Select a department.
3. Select the Workstation demand tab.
4. In the Maintenance workstation demand section in the bottom of the window, select a

workstation demand set.
5. Click the Open button.
6. Enlarge the window so you can see the entire timeline.
7. In the Workstation demand window, for a specific workstation, add a time frame:

n Select a block for the start time, press Shift, and select a block for the end time.
n Or, select a block for the start time, click the left-mouse button and drag the mouse to

the block of the end time. Release the mouse button.
n a blue colored time frame has been created.

8. Place the cursor somewhere in the blue colored time frame, and push the right-mouse
button.

9. Go to New workstation demand > New workstation demand. Or press Control + Insert.

The time frame changes into an actual time bar representing a new workstation demand.

When the Workstation demand window is set into day mode (see previous section), entering a
new workstation demand will create a recurring demand by default. When the window is in
date mode, the new workstation demand will be created for the selected date only.

10. To adjust the properties of the workstation demand, either double-click on the time bar or
move the cursor above the time bar, push the right-mouse button, and select Properties.

Or, select the time bar and push Control + E.
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Example

n Enter a Name and Description.
n To move the time bar to another workstation, select another Workstation from the

drop-down list.
n Select an Activity type if it wasn't defined when creating the workstation. You can't

select a different activity type when it has already been defined, unless a Default
activity type was defined during configuration. For more information, see step 5 in
"Add workstations to locations" on page 3.

n Select the Days the workstation demand is valid.
n Adjust the Begin time or End time of the workstation demand. As a result, the Duration

will be recalculated and adjusted.
n Adjust the Duration. As a result, the End time will be recalculated and adjusted.
n Adjust the Required labor time. This can be shorter than the demand duration.

The required labor time indicates how much time the workstation needs to be occupied
within the begin- and end time boundaries. This is relevant for the workstation
optimizer and makes it possible to indicate that the workstation needs to be occupied
for 3 hours within the period of 12:30h until 16:30h. In this case, the workstation
optimizer will assign an employee that will occupy this workstation for 3 hours.
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n Define the Duration period of the workstation demand. The duration period can be
used to create non-weekly demands, for example bi-weekly.

n To define if and how this workstation demand can be broken down, select the
checkbox The demanded activity can be broken down by the optimizer into n hour.
Define the time block. For example, 00:30 minutes.

This determines if the demand has to be assigned in one part to the same employee, or
that it can be split up in multiple parts and assigned to multiple employees.

n Set the Priority of the demand. The optimizer will use this information in case not all
demands can be assigned. It will prioritize the demands with the highest priority.

n Enter the Number of employees. This number represents the actual demand value.
n Click OK.

11. To add more workstation demands, repeat from step 7.
12. Click OK.

2.2.3 Edit or delete demands per workstation
1. Go to Planning > Schedule management.
2. Select a department.
3. Select the Workstation demand tab.
4. In the Maintenance workstation demand section in the bottom of the window, select a

workstation demand set.
5. Click the Open button.
6. Enlarge the window so you can see the entire timeline.
7. To delete a workstation demand, select it, push the right mouse button and click Delete. To

confirm, click OK.
8. To adjust the properties of a workstation demand, either double-click on the time bar or move

the cursor above the time bar, push the right-mouse button, and select Properties.

Or, select the time bar and push Control + E.

n Adjust the Name and Description.
n To move the time bar to another workstation, select another Workstation from the

drop-down list.
n Adjust the Activity type, but only if it wasn't defined when creating the workstation.
n Adjust the Days the workstation demand is valid.
n Adjust the Begin time or End time of the workstation demand. As a result, the Duration

will be recalculated and adjusted.
n Adjust the Duration. As a result, the End time will be recalculated and adjusted.
n Adjust the Required labor time. This can be shorter than the demand duration.

The required labor time indicates how much time the workstation needs to be occupied
within the begin- and end time boundaries. This is relevant for the workstation planning
generator and makes it possible to indicate that the workstation needs to be occupied
for 3 hours within the period of 12:30h until 16:30h. In this case, the workstation
planning generator will assign an employee that will occupy this workstation for 3
hours.

n Adjust the Duration period of the workstation demand. The duration period can be
used to create non-weekly demands, for example bi-weekly.
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n Adjust if and how this workstation demand can be broken down. Select the checkbox
The demanded activity can be broken down by the optimizer into n hour. Define the
time block. For example, 00:30 minutes.

This determines if the demand has to be assigned in one part to the same employee, or
that it can be split up in multiple parts and assigned to multiple employees.

n Adjust the Priority of the demand. The optimizer will use this information in case not
all demands can be assigned. It will prioritize the demands with the highest priority.

n Adjust the Number of employees. This number represents the actual demand value.
n Click OK.

9. Click OK.

2.2.4 Activate workstation demand set
Activate a workstation demand set so you can use it when creating a (workstation) planning.

1. Go to Planning > Schedule management.
2. Select a department.
3. Select the Workstation demand tab.
4. In the Workstation demand [department name] section, in the upper half of the tab, click the

New button.
n In the Workstation demand window, define the Period.

When no end time is defined, only one workstation demand set can be active. Set the
end time, to be able to activate multiple workstation demand sets for different periods.

n Select a Workstation demand from the drop-down list.
n Click OK.

To edit an activated workstation demand set, select it and click the Open button.

Only the highest (most recent) and lowest (oldest) lines can be deleted; select the line and click the
Delete button.

When you remove the lowest (oldest) line from the overview, it's not possible to easily re-enter this line,
because you can only add new lines at the top of the overview.
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3 Plan workstations manually
Plan workstations indirectly through duties or directly by assigning workstations to employees
based on their availability. Workstation assignment can be done manually, as described in this
section, or automatically via the "Workstation optimizer" on page 26. Each method enables you to
create a finalized planning. A combination of these methods is also possible.

3.1 Assign workstations indirectly
Plan workstations indirectly through duties, by assigning workstations to its activities in the duty
form. When a duty is required to be performed at the same workstation each time, you can assign
the workstation to the default duty. This way, when the duty is assigned to an employee in the
master schedule, it's automatically linked to the designated workstation. This helps in ensuring
efficiency and reduces the chances of confusion or error.

3.1.1 Assign workstations to duties
1. Go to Planning > Schedule Management.
2. Select the Duty sets tab.
3. From the Maintenance duty sets section, at the bottom-left corner, select a duty set.
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4. Click the Open button.

Example

5. From the Name drop-down list, select a duty.
6. In the Activities section, beneath the Workstation column, select the cell related to the

activity you want to add a workstation to.
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7. Select the arrow button and from the drop-down list, select a workstation for this activity.

Example

8. Repeat step 5 to 7 for as many duties and activities as you want.
9. Click OK.

10. Repeat step 3 to 9 for as many duty sets as you want.

You can also indirectly assign workstations to one-time duties, or single instances of duties
(=shift) in the master schedule.

3.2 Assign workstations directly
Plan workstations directly in the workstation plan board by assigning workstations to employees
based on their availability. Workstation assignment can be done manually or automatically via the
Workstation optimizer. In this section we'll describe the manual assignment of workstations to
employees. For more information on using an optimizer for workstation planning, please refer to
"Workstation optimizer" on page 26.

3.2.1 Assign workstations manually to employees
1. Go to Planning > Workstation planning.
2. Select a Department from the drop-down list.
3. Define a Period. The maximum period for which the workstation plan board can be opened is

7 days.
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4. Click OK.

n Most functionalities are equal to the master schedule.
n Use the arrow buttons or scroll bars to navigate through the board.
n Additional functionality can be reached by either selecting a cell and clicking the right

mouse button, or by double clicking on a cell.

5. Choose a method to proceed:
n assign workstations to employees via Employee proposal, or
n assign employees to workstations via Workstation proposal. or
n assign workstations to new activities.

3.2.2 Employee proposal

In the bottom half of the window, you can view per workstation the assigned employees. Here you
can also view the under- or overstaffing per workstation.

1. To assign a workstation to an employee, select - in the Classification of workstations pane -
a workstation demand.

2. Push the right mouse button and select Employee proposal.
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3. (Optional) Select another period from the Selected period drop-down list.

Example

4. View the names of the Permitted and Not Permitted employees. Each section is divided into
Fully available, Partly available and Not available. For each employee, view:

n the time frame for which each employee is fully, partly, or not available
n the current workstation of the employee. This column also reflects the shift changes

that occur when an employee is selected. It may involve combining existing activities
or creating a new shift to meet the workstation demand entirely.

n the experience hours. This shows the number of hours that the employee has already
worked on the concerned workstation in the past n days.

n remarks. If the employee has a shift with a shift remark, the shift remark will also be
visible here.

5. Select an employee from the list.
6. Click OK.

The workstation is assigned to an employee.

3.2.3 Workstation proposal

In the upper half of the window, you can view per employee the assigned workstations.
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1. Right-click one of the employee's activities.
2. Select Workstation proposal.
3. View the names of the Permitted and Not Permitted workstations. Each section is divided

into Understaffed and Selected period. For each workstation, view:
n the time frame
n the possible workstation(s) to assign the employee to
n the activity type
n remarks

Example

4. Select a workstation from the list.
5. Click OK.

The employee is assigned to a workstation.

3.2.4 Assign workstations to new activities

Sometimes it's not possible to assign the (entire) workstation demand to existing employee
availability (activities). If so, the workstation plan board provides options to add new activities before,
during or after an existing activity. The (remaining) workstation demand can then be assigned to the
newly created activities.

1. Define - in the upper pane - a time frame.
n Select a cell with the begin time, push Shift, and select a cell with the end time.
n Or, select a cell, drag the mouse to the end time cell and release the mouse button.

2. Make sure the selection overlaps with at least one existing activity.
3. Click the right mouse button on the existing activity within the selected time frame and select

Add activity.
4. Depending on the selected time frame, you can choose from:

n Before selected activity
n After selected activity
n During selected activity

5. (Optional) Repeat step 1 to 3 to add more time frames and activities.
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6. Add a workstation to one or more activities:
n Right-click on an existing activity.
n Select Change workstation.
n Select the correct workstation from the list. It might be that the workstation is shown

under the sub menu Other.
Only workstations that an employee is qualified for are shown.

Example

Alternatively, double click on an activity or scheduled workstation. In the Activities tab, add activities.
Per activity, change the description and select a workstation. You can also adjust the Begin and End
time. Add an address where the workstation is located. Click Apply.

3.2.5 Delete activities
1. Right-click on an existing activity.
2. Select Delete activity.
3. To confirm, click Yes.

The activity with (possibly) allocated workstations is deleted.

3.2.6 Change assigned workstations
1. Click with the right mouse button on a workstation.
2. Select Change workstation.
3. Select the correct workstation from the list. The workstation might be shown under the sub

menu Other > [Workstation name].
Only workstations that an employee is qualified for are shown.

3.2.7 Delete assigned workstations
1. Click with the right mouse button on a workstation.
2. Select Change workstation.
3. Select (None).

The workstation is removed from the time frame.

It's possible that, after deleting a workstation, a different activity type is displayed than expected. In
that case, double click on the activity and select another activity type.
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3.2.8 Edit employee on workstation
1. Select - in the Classification of workstations pane - a workstation.
2. Push the right mouse button and select Change employee.
3. Select an Employee from the drop-down list.

Sometimes it's not possible to select a specific employee and you'll get a notification.

4. (Optional) Adjust the Period.

It's not possible to adjust the period, when another employee was scheduled for this
workstation. Otherwise it's possible to adjust the period.

5. Click OK.

3.2.9 General settings

Adjust timeline

Use the Zoom in and Zoom out buttons to adjust the scale of the timeline.

When those buttons are not available, adjust the scale manually via the dropdown menu above the
timeline:

Show or hide calculations, counters and violations
1. With the Workstation planning board open, go to View > Plan board components.
2. Select the components you want to show (not selected is not shown):

n Employees
n Employee calculations
n Violations
n Vacant shifts
n Shift counters
n Daily calculations
n Daily requirements
n Classification or workstation
n Violations (text)
n KPI calculations
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3.2.10 Sort and filter

Sort employees or workstations
1. With the Workstation planning board open, select either the Sort employees or Sort

workstations button: 

Hover with your mouse above the buttons to find the correct one. The button on the left
usually is the Sort employees button.

Sort employees is also available via View > Sort.

2. Select one ore more criteria you want to sort on and order those criteria. The criterion on top
will be sorted on first, and subsequently the other ones.

3. Define the Reference date.

This date is important for a few criteria (like the sort category) that can change over time.

4. Select, per selected criterion, Ascending or Descending.
5. (Optional) View the summary on how the sorting is done.
6. Click OK.

Filter employees, workstations or vacant shifts
1. With the Workstation planning board open, select either the Filter employees, Filter

workstations or Filter vacant shifts button: 

Hover with your mouse above the buttons to find the correct one. The button on the left
usually is the Filter employees button.

Filter employees is also available via View > Filter.

2. Select one ore more criteria you want to filter on.
3. Within each criterion, make a selection. To select all, select the checkbox Select all.
4. (Optional) View the Summary on how the filtering is done.
5. Click OK.

Only employees, workstations or vacant shifts that meet the established criteria are
displayed.

3.3 Reports and calculations

3.3.1 Report Workstation planning
The report Workstation planning shows per department where and when employees are scheduled.

n Go to Reports > Workstation planning.
n Define a period, select a department, and define how the information must be displayed.
n Click View Report.
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Example

3.3.2 Overview Workstation occupation analysis
The overview Workstation occupation analysis – which can be opened from the menu Overview or

by clicking the equally named button on the toolbar - shows the under- and overstaffing for the
selected workstations in the selected period, based on the workstation demands and assignments
of the selected department. The authorization WSN_DEM_OVERVIEW is needed to be able to open
this overview.

In this overview you have the option to compare the workstation demands with:

n assignments in the master schedule (where you can also decide to include vacant shifts as
well)

n assignments as per the activated duty and duty demand set in the selected period
n assignments in a specific duty set and duty demand set (which you can then choose from).

When you change the settings in this analysis overview, press the button Refresh to actualize the
overview.
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It's also possibly to display the analysis in a graphical manner on the tab Graphical overview, where
you have the option to:

n sum the workstation demands and assignments for all selected workstations together or
show them individually per workstation

n enable and disable graphs for the demands, the assignments, the understaffing and the
overstaffing
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4 Workstation optimizer
In order for the Workstation optimizer to be activated, the Global Setting UseWorkstationPlanner
must be activated from within ORTEC WS Settings Manager. Contact your ORTEC representative
when needed.

Creating a shift schedule differs greatly to workstation planning. Workstation planning entails
assigning employees to workstations, whereas shift planning entails allocating shifts (possibly with
workstations) to employees. It's essential to realize that two constants are assumed during
workstation planning:

n employee availability
n workstation demands

With these constants in mind, the workstations are filled with available employees. Assignments
can be carried out manually (for more information, see "Plan workstations manually" on page 15) or
automatically optimized with the Workstation optimizer. In this section, we will:

n describe the overall operation of the Workstation optimizer
n outline all available configurations
n demonstrate the effects of the various configurations on the outcome

Workstation optimization and the configuration of the Workstation optimizer is an advanced user
component. It is assumed that the reader is familiar with the Workstation planning features.

4.1 Planning profiles
When automatically assigning employees to workstations, it's desirable to consider various user-
defined decision rules. An example of such a rule or criterion might be, 'A user may only work at
their preferred location.' Furthermore, the planner may choose to automatically assign only a
portion of the employees, or to assign them only to a portion of the workstations. These criteria and
conditions are recorded in profiles. Whenever a schedule is generated automatically, one or more
profiles are executed in sequence. The execution of profiles and the various settings and rules that
can be configured within a profile are detailed below.

4.1.1 Profile settings
An overview of the available workstation planning profiles is displayed under the menu option
Optimizers > Workstation optimizer profiles. Profiles are created for each department and are
located in the top section of the screen. The profile settings are displayed across three tabs in the
bottom section of the screen. Employees and workstations to be assigned can be selected on the
second and third profile tabs respectively.
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Example

A practical application for the employee setting is the situation in which regular employees and
trainees need to be assigned. In one profile, only regular employees are selected and in the other,
only trainees. Initially, a schedule is generated using the employee profile followed by a schedule
using the trainee profile. If a rule is added to the trainee profile (for more information, see
"Cooperative associations" on page 30), which states that trainees may only be assigned to
workstations where an employee has already been assigned, a schedule is created that – due to the
corresponding setting – satisfies this rule.

The first profile tab contains the profile rule sets to be defined. Rules can be registered within a set.
These rules are listed in the next section. A rule set is added to a profile by checking the box.

In the second profile tab, employees can be selected for which the profile applies. You can select
all employees of the department, or select specific employees.

In the third profile tab, workstations can be selected for which the profile applies. You can select all
workstations of the department, or select specific workstations.

Last, the profile setting can be selected: ‘Consider subsequent profiles’. This option is relevant in
the event that multiple profiles have been defined and are executed in succession. If this option is



ORTEC Workforce Scheduling 7 User Manual Module Workstation Planning
28

© 2025, All rights reserved Workstation optimizer

disabled, the Optimizer will assign as many employees to workstations as possible for each profile.
Profiles are executed sequentially; therefore, it is possible that full utilization of the first profile
means that the second and third profiles make fewer assignments. This occurs because it is
assumed that the sequence of profiles indicates their importance or priority. An assignment
resulting from the first profile is therefore considered more important than two assignments from
the second profile. A possible outcome is that the total number of assignments made is not the
maximum achievable. Selecting this option considers subsequent profiles, thus increasing the total
number of assignments.

Example

Suppose that a schedule must be created whereby two employees (1 and 2) are assigned to two
workstations (A and B). Employee 1 may work at either workstation and has a preference for
Workstation B, while Employee 2 may only work at Workstation B. The schedule is created using two
profiles: Profile 1 assigns Employee 1 and Profile 2 assigns Employee 2.

If subsequent profiles are not taken into consideration, the following ensues. Profile 1 assigns
Employee 1 to Workstation B because this is his/her preferred workstation. Profile 2 then makes no
assignment because Workstation B is already occupied by Employee 1, and Employee 2 may not work
at Workstation A. However, if subsequent profiles are taken into consideration, then both employees
can be assigned. Maximization of employee assignments always takes precedence over personal
preferences in first-run profiles.

4.1.2 Profile rules
After the workstations and employees to be assigned for each profile have been selected, profile
rules may be set to further influence the planning. Each department has its own set of profile rules,
which are available to all profiles of that department. Profile rules are configured as weighted
criteria or requirements.

To understand the difference, it must be noted once more that the Optimizer makes its
assignments based on employee availability and workstation demands. Costs are attributed to an
assignment in order to make it a less attractive option. The higher the weighting applied to a rule,
the higher the cost when the rule is breached. If a rule is configured as a requirement, the rule can
no longer be breached.
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Example

Suppose that Employee 1 is available between 12:00 and 13:00. During this period, there are
workstation demands defined for Workstations A and B. The demands are identical and the employee
is qualified to work at both workstations. There are two possible assignments for which the
Optimizer has no particular preference, and the choice is then random. Both assignments cost the
same; assume a value of 1.

Suppose that in practice, Employee 1 has a preference for Workstation A. Suppose that assignments
are made using the profile ‘Preferred locations’, weighted with a value of 10.

The two possible assignments discussed above are no longer equal due to the addition of this profile
rule. The assignment of the employee to Workstation A is more attractive since this is his/her
preferred workstation. In cost terms, the assignment to Workstation A remains unchanged (1),
whereas assignment to Workstation B would cost 1 + 10 = 11 (standard cost + penalty for not
complying with the criterion). Since these costs are higher, the Optimizer will therefore opt to assign
Employee 1 to Workstation A. By raising the value for this criterion, assignment to Workstation B
becomes an increasingly less attractive proposition. Please note that raising this weighting value is
only worthwhile when additional rules have been implemented.

Finally, the profile rule can be set as a requirement. The option to assign Employee 1 to Workstation B
is no longer valid because this workstation assignment would not comply with the requirement.
Please note that the use of requirements can severely limit the total final number of assignments.

The various profile rules that can be set are activated from within the Global Settings in
ORTEC WS Settings Manager. Moreover, the following authorizations are required in order to view
and/or modify profiles and rules:

n WSN_PLANNER_PROFILE_READ – to view profiles
n WSN_PLANNER_PROFILE_WRITE – to edit profiles
n WSN_PLANNER_RULE_READ – to view profile rules
n WSN_PLANNER_RULE_WRITE – to edit profile rules

An overview of all the available profile rules is shown below.

Employee experience on workstation

Employee experience on workstation

General settings > Rules workstation engine > WPRuleExperienceHoursInPeriod.

This rule will prioritize scheduling employees on workstations on which they, compared to their
colleagues, have worked the least number of hours in the past 30 days. That will make sure their
experience level is kept up to date. The default number of 30 days can be changed to anything
between 1 and 365. However, if the number of days exceed the buffered history, the buffered
history will be used in the calculations instead.

Avoid overlap with leave request

Avoid overlap with leave request
The rule avoids assigning employees with a leave request to a workstation. As leave requests
can have different status, choose which status are relevant:
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n Open
n Concept approved
n Approved

The rule can be set as a criterion and requirement. When set as criterion, a penalty is calculated
when overlap is not avoided.

Cooperative associations

Cooperation with mentor
The rules schedules an employee on a workstation or location where he is monitored. Only set
work relations of the following types are relevant:

n Mentored by
n Instructed by

Work relations can be set in 'Employee management' under tab 'Work relations'.

The rule can be set as a criterion and requirement. When set as criterion, a penalty is calculated
when cooperation is not realized.

Divergence from current plan

Divergence from current plan
The rule avoids scheduling employees on another workstation or location than where they are
already assigned. Two additional options are available:

n Employees without assigned workstation are (not) affected by this rule.
n If selected, only already assigned workstations with a configurable priority are affected by

this rule.

The priority of the workstation demand can be set in 'Maintenance workstation demand' by
editing the properties of a specific demand.

The rule can be set as a criterion and requirement. When set as criterion, a penalty is calculated
when an employee is reassigned.

The rule does not apply when selecting the option 'Always save' in the 'Processing of existing
assignments' part of the optimization engine window. Selecting this option does not reassign
employees.

Preferred employees

Preferred employee of workstation demand
The rule schedules specified preferred employees to the workstation demand.
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Preferred employees for workstation demand can be set in 'Maintenance workstation demand' by
editing the properties of a specific demand.

The rule can be set as a criterion and requirement. When set as criterion, a penalty is calculated
when an employee is less preferred.

Preferred locations

Preferred locations
The rule takes preferred locations of employees into account when scheduling workstations. You
have to choose between the two options:

n Use the percentage of preferred location as probability the employee is assigned to the
location.

n Use the percentage of preferred location as desired distribution of employee working
locations. The generator compares this desired distribution with the scheduled
workstations in the planned period, including a configurable number of days in the past.

The employee preferred locations can be set in 'Employee management' in the tab 'Preferred
locations'.

The rule can be set as a criterion and requirement. When set as criterion, a penalty is calculated
when an preferred location of an employee is not realized or the desired distribution is not met.

Preferred workstations and locations of 0 percent
If a employee preferred location is set to 0%, the employee is not allowed to work at that location.

See 'Preferred locations' on how to set employee preferred locations.

The rule can only configured as a requirement.

Priority of workstation demand

Priority of workstation demand

General settings > Rules workstation engine > WPRulePriorityDemand.
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The rules schedules workstations with a higher priority demand first. Without this rule, the set
priority of the workstation demand has no influence on the Workstation Optimizer.

See "Divergence from current plan" on page 30 on how to set the priority of a workstation
demand.

The rule can be set as a criterion and requirement. When set as criterion, the priority of a
workstation demand is taken into account when calculating the penalty.

Variation compared with past

The same workstation as in the past
The rule assigns employees to the same workstation or location as in the past. The number of
days in the past is configurable. Two additional options are available:

n If a penalty has to be calculated due to a violation, scale the penalty to the number of days
in the past. A penalty for not assigning the same workstation/location as yesterday is
higher than a penalty for not assigning the same workstation/location as seven days ago.

n If a penalty has to be calculated due to a violation, scale the penalty to the realized
percentage in the past. When not selected, the penalty only looks whether the employee
was or was not assigned to the workstation/location. When selected, the duration on this
workstation/location is taken as percentage of the total duration assigned to workstations.

The rule can be set as a criterion and requirement. When set as requirement, the two options are
not available. When set as a criterion, violations of the rule create a penalty.

Workstation other than in the past
The rule assigns employees to a different workstation or location as in the past. The number of
days in the past is configurable. Two additional options are available:

n If a penalty has to be calculated due to a violation, scale the penalty to the number of days
in the past. A penalty for assigning the same workstation/location as yesterday is higher
than a penalty for assigning the same workstation/location as seven days ago.

n If a penalty has to be calculated due to a violation, scale the penalty to the realized
percentage in the past. When not selected, the penalty only looks whether the employee
was or was not assigned to the workstation/location. When selected, the duration on this
workstation/location is taken as percentage of the total duration assigned to workstations.

The rule can be set as a criterion and requirement. When set as requirement, the two options are
not available. When set as a criterion, violations of the rule create a penalty.

Variation within the planning period

Other workstation within period
The rule schedules an employee within a period to a different workstation or location. You can
choose three periods as configuration:

n The period to be planned in
n A shift
n A series of activities
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The series of activities depends on the choice for 'assign workstation demands to' in the
optimization engine windows. Here, one of the following options have to be selected:

n Activities with the same activity type
n Activities with the same main activity type
n Activities with the same type
n Activities with/without work
n All activities

The rule can be set as a criterion and requirement. When set as a criterion, violations of the rule
create a penalty.

The same workstation within period

General setting WPRuleSameInPeriod.

The rule schedules an employee within a period to the same workstation or location. You can
choose three periods as configuration:

n The period to be planned in
n A shift
n A series of activities

The series of activities depends on the choice for 'assign workstation demands to' in the
optimization engine windows. Here, one of the following options have to be selected:

n Activities with the same activity type
n Activities with the same main activity type
n Activities with the same type
n Activities with/without work
n All activities

The rule can be set as a criterion and requirement. When set as a criterion, violations of the rule
create a penalty.

4.2 Schedule generation
Once the profiles have been configured, a workstation schedule can be generated from the
workstation master schedule. The following screen is displayed by selecting Optimizer >
Workstation optimizer. To be able to select this option, the Workstation plan board needs to be
opened in the client.
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Figure 4.1: Select details to display all settings.
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.
Figure 4.2: The various planning parameters used to generate a schedule. These can be saved as parameters by
selecting Save or ‘Save As’ at the bottom of the screen
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4.2.1 Profiles to be executed
The screen displays all settings that are not profile-dependent. These settings apply equally to all
profiles executed. These are the profiles selected in the center of the right-hand screen. Please
remember that the order in which profiles are executed can alter the final outcome of the planning.
For this reason, this sequence can be adjusted in this screen.

4.2.2 Assign workstation demands to activities
Define how the workstation demands can be allocated to the available employees by matching the
underlying activities of each workstation demand with the activities of the available employees.
There are five options available, each widening the scope of how strictly the demand should match
the available employees. The wider the scope, the more possible assignments the Optimizer can
generate. The five options are:

1. Activities with the same activity type
Only the same activity types can be merged and matched.

2. Activities with the same main activity type
All activity types that belong to a higher hierarchical activity type can be merged and
matched, including all activities from option 1.

3. Activities with the same type
All activity types that have the same activity class can be merged and matched, including all
activities from option 2.

4. Activities with/without work
All activity types that count as working hours can be merged and matched, including all
activities from option 3.

5. All activities
All activities can be merged and matched.

The assignment of the Workstation optimizer works in two levels:

1. Merge the activities on the demand side and the employee side, based upon the chosen
option of 'assign workstation demands to'.

2. Match the activities of the workstation demand and the available employees.

The configuration of activity types determines the merging step.

The Optimizer tries to match the exact activity duration as defined in the workstation demand on an
available employee. The option 'the demanded activity can be broken down' influences the matching
step. This option can be configured in the workstation demand properties window.

4.2.3 Processing of existing assignments
Another setting that has to be configured is ‘Processing of existing assignments’. This relates to
availability processing before a schedule is generated. An employee who has already been
assigned to a workstation (manually or by the Optimizer) can by default (first option) no longer



37
User Manual Module Workstation Planning ORTEC Workforce Scheduling 7
Workstation optimizer © 2025, All rights reserved

fulfill other workstation demands. Once assigned, the assignment remains in place. Automatic
planning only caters for additional assignments.

This can be circumvented by selecting the option ‘Unassign all workstations’. This setting removes
all existing assignments before commencing automatic planning. Please note that it is therefore
possible that an employee presently assigned to Workstation A, could subsequently be assigned to
either Workstation A, B or no workstation at all! A variant setting is to only take the workstations as
defined in the profile into account.

Unassigning all workstations is not always a desired result and for this reason, there is an
‘Overwrite’ option. This option ensures that an existing assignment is only deleted when a new
assignment is available in its place. An employee presently assigned to Workstation A either
remains assigned to Workstation A or is reassigned to another workstation when use is made of
this option. The employee remains assigned. A variant setting is to only take the workstations as
defined in the profile into account.

4.2.4 Other settings
n When 'Assign workstations to fixed shifts' is enabled, fixed shifts will be used by the

optimizer.
n If the option ‘Merge activities with the same workstation’ has been selected, all consecutive

activities for the same workstation with the same activity type will be merged into one
activity once the Optimizer has run for all shifts.

The workstation optimizer takes all non blocked shifts into account. Shifts that are blocked
will not be updated by the optimizer.
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